Frenzy - FreeBSD-based LiveCD


  help me out with USB please

section "Support" >>

(vineyard saker)
25.06.2006 (02:15)


I am using Frenzy 'extended' 1.0. I attached a flash memory stick to its USB port but even though I tried for a long while I could not mount this device. First, even though I booted up the system with the device in its USB port, /mnt/fstab did not create a subdirectory to mount a usb device. I tried the various usb detection utilities which did *see* the device, but provided me with no info as to how I could mount it. /dev did not contain any usb subdirectory...

what is the correct procedure to mount a usb device with Frenzy?

Many thanks,


PS: I look at the FAQ, the handbook and the Frenzy help but I did not find this info :-(

(Mozhaisky Sergei)
25.06.2006 (14:17)

What is exact name of device?
Can you sent via e-mail to me ( file /var/run/dmesg.boot from Frenzy, when system booted with this device in USB port?

(Mozhaisky Sergei)
26.06.2006 (12:23)

I've received requested files.
It seems that your USB Stick detected OK (as /dev/da0 device). You may see partitions from it as /dev/da0s1 and so on (and they must be automounted to /mnt/da0s1.fat for example).

If no partitions are found and mounted, try to execute this commands after inserting USB stick (dirty hack :)

dd if=/dev/null of=/dev/da0 count=0
frmount auto

(vineyard saker)
27.06.2006 (15:25)

I tried your hack and here is what happened.

After I did 'dd if=/dev/null of=/dev/da0 count=0' I got:

0+0 records in
0+0 records out
0 bytes transferred in 0.000087 secs (0 bytes/sec)

and after I did "frmount auto" I got the normal frmount info searching for HDD slices and Mounting Partition: [] done.

However, when I did mount I did not see any:

/dev/da0s1 on /mnt/da0s1.fat or anything like it.

In fact, the subdirectory did not even have a /da* subdirectory created...

I also found a couple of minutes to sit down and try to play around with two other USB flash memory sticks. It turns out that Frenzy can mount one of the two, but not the two others (the one he can mount is a Lexar JumpDrive wih 128MB).

I looked at the kernel messages and each time I connect one of these devices, the kernel sees them but nothing happends to /dev or /mnt.

Also - I tried umounting the Lexar and mounting it back again, but then I get an error message.

How mature is USB support in FreeBSD? I have a sense that the FreeBSD kernel does ok seeing some, but not all, USB storage devices on boot and that any subsequent mounting unmount thereafter is a challenge.

Is there any way at all I can get Frenzy to see my USB devices? I really, REALLY need them as I never use floppies...

(vineyard saker)
28.06.2006 (08:47)

Now I am having second thoughts about it all. I experienced some strange problems with my USB devices on my GNU/Linux systems and I strat suspecting that either a) I did something wrong while tring to mount them with Frenzy or b) that I have a hardware problem somewhere which is trashing my USB devices. Either way - I am not at all that sure anymore that Frenzy has anything to do with this.

I will look into this and come back as soon as I find out what was going on.

I apologize if I inadvertantly raised a false alarm

1.07.2006 (02:00)

I have a problem with a Western Digital 250GB USB external hard drive.

If I boot Frenzy with the drive connected to the usb port Frenzy freezes. If I connect it to the usb port after Frenzy boots, the kernel does see it and correctly identifies it, but I see no command like mount_vfat to mount it. When I simply go mount /dev/dao (or whatever the correct device designator is) /mnt/usb (which I created) I get a 'bad superblock' message.

With linux all I need to do is 'mount /dev/sda1 /media/sda1' and the device mounts. How can I do this with Frenzy?


(Mozhaisky Sergei)
1.07.2006 (02:25)

You must specify filesystem:
mount_msdosfs /dev/da0s1 /mnt/usb
mount_ntfs /dev/da0s1 /mnt/usb
or you can run Frenzy-specific command
frmount auto
which will automount all partitions from new disks.
See for details.

But I suppose you are using single FAT partition on this drive. FreeBSD has only experimental support of FAT filesystems bigger than 128Gb, so I've not included support of this option to Frenzy.

1.07.2006 (06:10)

frmount does not seem to mount my usb devices, not does it mount my CD in CD drives. It only seems to work on HD partition.

You write "FreeBSD has only experimental support of FAT filesystems bigger than 128Gb, so I've not included support of this option to Frenzy."

Should I repartition this 250GB drive into several smaller partitions?

Also, since I will use vfat on all the partitions on this device, should I do:

a) 'mount_msdosfs /dev/da0 /mnt/usb' (or 'mount_msdosfs /dev/da* /mnt/usb*' for several partitions smaller than 128GB)


b) 'mount_devfs /dev/da0 /mnt/usb'(or 'mount_devfs /dev/da* /mnt/usb*'for several partitions smaller than 128GB)

to mount my device?!?

Many thanks for any further help!

2.07.2006 (22:26)

"Should I repartition this 250GB drive into several smaller partitions?"

Maybe this is the best thing to do.

I have an external USb HDD 160 GB in 6 partitions and have no problems mounting those partitions.

Give you two entries of my '/etc/fstab/' :
/dev/da0s1 /mnt/sda1 ntfs ro,noauto,-Wkoi2dos 0 0
/dev/da0s5 /mnt/sda5 msdos rw,auto,longnames,-Wkoi2dos 0 0

Hope this helps.

8.01.2007 (12:08)


Depending on your configuration of your users privileges, you can su to your superuser account and mount a usb disk in the following way.

1. With your super user logged on, create a new directory in your / called 'external' with mkdir /external
2. plug in your usb disk
3. You should see some output to a console detailing the nature of the device plugged in. If it is not outputted to your current console, switch to tty1/2/3 and you should see it there. If not, type dmesg | tail and it should be outputted to your screen. You can see any device failures in hardware recognition that will cause problems in mounting there.
4. if your disk is the only usb device it will be named da0s1
5. So the command you need is (depending on the file system..if your disk is larger than 4gb and you were using windows XP when you formatted it will be of the type ntfs) mount_ntfs /dev/da0s1 /external
6. If that basic mount was successful, then you should now be able to cd to /external and access your files.

I hope that helps!

  [ 1-10 of 10 ]

m-forum v0.85d

Rambler's Top100